Issue with turn off/on wifi on satellite p845-s4200

Posts: 1

Issue with turn off/on wifi on satellite p845-s4200

I have p845 with win7 upgraded to win8 and tp-link tp-wr841n wifi router.


Right after upgrading to win8 wifi worked perfectly. But yesterday I've turned wifi off/on using fn+f12. After that I am able to see wifi networks around but I can't connect to any of them (protected/not protected doesn't matter). I've tried to install latest wifi drivers from intel website, tried to restore originals from win8. Reboot and turn off doesn't help too. So I've left laptop overnight to restore windows to the factory defaults and upgrade again.


At morning I've opened laptop and successfuly connected to wifi. I've checked system logs and found that the only thing happened at night was changing state to s4 hybernate. So I've turned off/on wifi again (it broke again) and sent laptop to sleep using on/off button above keyboard. And it worked, wifi successfuly connected.


Anyone knows how to fix this?