Reply
Member
albertjve
Posts: 6
Accepted Solution

Hotkey and WLan not working

Hi,

 

Just updated my L500 PSLJ3E Notebook from Vista to Win7, using the Toshiba upgrade disc. Both versions Home Premium 64bit.

 

Now it seems I can not switch on my WLAN (was switched of during migration as instructed). The hotkeys appeared to be not working anymore, so no luck with Fn-F8.

 

 Configfree reports that wlan is switched on but cannot search network, and says adapter is down. After troubleshooting it comes back with suggestion to switch wlan adapter on. Similar effect & suggestion with windows networkcenter and troubleshooter.

 

 At boot -F2 setup menu WLAN appears to be switched on. Toshiba HW utility says it is on.

 

done so far:

updated most software to latest version and upgraded BIOS to v1.80

I have switched off the powersave function for the WLan device

 

still no luck.

 

I am pretty stuck now, but I want to avoid a clean Win7 install as my machine is pretty complete and it will take some time to reload the software.

 

Hope anyone knows how to fix this.

 

Cheers,

 

Albert

 

 

 

 

Member
albertjve
Posts: 6

Re: Hotkey and WLan not working

Update:

 

apparently I thought I installed the latest SW. Learned from forrum (post: about tvap) that install is buggy. Second time extracted files only and manually started setup. At least tvap seems to install now.

 

However Fn functions still do not work. Nor does WLAN.

 

Also issue with Intel chipset update. "System incompatible".  (while installing difxapi.dll)

 

Not a happy customer.

Member
albertjve
Posts: 6

Re: Hotkey and WLan not working

another update: installed Intel driver and wlan mgt sw. Again: radio hardware switch is off.

Checked again that Toshiba HW utility tells me that it is on.

 

Will revert to vista backup.

Member
albertjve
Posts: 6

FN Hotkey still not working so WLan on/off switch not working

Have restored vista backup,switched on WLAN with Fn-F8, restored W7 backup.

 

configfree now reports Wlan under W7 is now working fine. So definitely no HW failure.:smileyhappy:

 

The issue has to do with Fn-F8 to switch Wlan on/off.

 

There seems no other way to do this. And my FN-F key combinations are still not working.:smileysad:

 

Any suggestions how to get those Fn keys working??

 

Cheers,

Albert

Member
albertjve
Posts: 6

Re: FN Hotkey still not working so WLan on/off switch not working

After deinstalling and installing Toshiba's VAP Fn Keys still dont work. Also tried restarting. no luck.

 

HOWEVER... switching on mouse activation for flash cards appears to be a work around. at least all options are available again. Not the way I want, but after spending  4 hours on this stupid issue I can live with it.

 

@Toshiba support: please check the Fn keys in the next release of VAP (x64) for the L500 model.

Member
albertjve
Posts: 6

Re: FN Hotkey still not working so WLan on/off switch not working

@Toshiba support: Also to check: WLAN settings in BIOS do not seem to work under W7 for L500. You can set them but they do not change the WLAN operation. Check via boot menu as well as Toshiba HW setup.

 

Since I switched off under Vista before W7 migration, and Fn-F8 was not working, this was quite a pain.

Member
Bekali
Posts: 2

Re: Hotkey and WLan not working

Why nobody help us to use our laptops fine?? I payed 400 euro on my L500 PSLJ0E and i can use the wireless...

the Fn+F8 is not working.

Member
hermes122
Posts: 1

Re: FN Hotkey still not working so WLan on/off switch not working

Hello, I have just encountered and solved this problem. Here's the steps I took through the process:

 

1. Fn F8 not working (a few other problems too).  Formatted hard drive and removed Toshiba partition.

2. Installed Windows 7 Ultimate from a vendor other than Toshiba.

3. Installed correct wireless driver, which indicated the device was 'enabled'.  Ran Windows 'troubleshooter' which told me that the switch was off (duh). Couldn't use the hotkeys to re-activate.

4. Tested Fn independently, tested F8 independently.  Both working fine.

5. Installed Toshiba ConfigFree.  Didn't fix the problem.

6. Installed Toshiba Value Added Packed.  Started working.

 

Hope this helps someone!

Regular Contributor
Altair
Posts: 217

Re: FN Hotkey still not working so WLan on/off switch not working

That is good.

 

Config free has nothing to do with getting it to work.  It is an application.