Reply
Member
MikeS21
Posts: 4

Satellite P305D-S8995E Overheat AFTER Windows 7 Clean Install

It seems that my Satellite P305D overheats when I have some heavy graphics or watching video.  The machince locks up and shuts down.  I can run other programs, such as Office 2007, with no problems, so it seems to be video graphics related.

 

It only started doing this a couple weeks ago right after I did a clean install of Winows 7 x64.  Prior to that, I was running Vista Home Pemium x64 and had no problems with overheating or video.

 

All drivers are up to date, and hardware manager shows no problems.

 

The Satellite P305D has the ATI Radeon™ X1250 Graphics, and the CPU board is an AMD Turion™ 64 X2 Dual-Core processor.  The system has 4 GB of memory.

 

Any idea if this is a driver incompatability or what?

Member
MrWhite
Posts: 1

Re: Satellite P305D-S8995E Overheat AFTER Windows 7 Clean Install

[ Edited ]

My P305D is having the exact same problem. The weird thing is that I did not have the problem when I was running the Windows 7 release candidate which was installed as an upgrade to the original pre-installed Vista. When I installed the Window 7 retail release as a clean install, this overheat problem started. Possibly restoring the orginal Vista package and then installing Win7 as an update will correct the issue but that will be a lot of work.

Member
depriest
Posts: 1

Re: Satellite P305D-S8995E Overheat AFTER Windows 7 Clean Install

I wonder if that is what's happening to my laptop.  I have the exact same model.  I did the same thing, did the Windows 7 64 bit clean install, previous Vista Home Premium 64-bit.  Its happened to me a couple of times when I had 3-4 applications open, one being Adobe Photoshop Elements & Adobe Photoshop Lightroom, both resource intensive.  It will just freeze and shut down.  Did you find a solution?

 

I'm having 2 other problems also, which I'll probably post to other areas of this forum.

1) Laptop screen goes blank/black.  Software & hard drive does not shut down, just screen goes blank.  There is a bit of a glow on the screen, but I can't see the desktop.  This did not happen with Vista, but not sure its OS related. 

2) when I wake the laptop up from hibernation and open MS Outlook 2010 and then Chrome quickly afterwards the mouse & keyboard freeze and I have to hard boot the laptop to get it to work again.  My guess its not application related, but waking from hibernation/sleep mode.

 

Sarah