Reply
Member
mking
Posts: 4

L505-S5990 webcam is not working

Just got home with a new Toshiba Satellite L505-S5990 running Windows 7 (32-bit).  Everything seems to be working ok except the webcam.  Every time I start up the computer or the Web Camera Application, I get a dialog from the Web Camera software:


"Web camera initialization failed.Please check your camera device and restart application or computer."

 

Of course, restarting either the computer or the application just gives me the message again.

 

In the device manager, there is an Unknown USB device.  If I click on that, it says "Windows has stopped this device because it has reported problems (Code 43)".  I'm assuming that this is the camera, but why is it not working?  Is there a specific device driver I need for the webcam under Windows 7?

 

I've tried downloading the new Web Camera Application, but it doesn't change anything.  It runs, and doesn't seem to do anything.  From what I can see, I already had the same version on my computer (1.1.1.4).

 

I tried selecting a new driver for the device, but I don't know the manufacturer for the camera, and there are a few too many to guess!  If anyone knows what the camera device driver is named, let me know, and I'll try setting that as the device driver.

 

Any help would be greatly appreciated!  Thanks!

Regular Member
brunke
Posts: 9

Re: L505-S5990 webcam is not working

I have a Satellite L505-S6951, running Windows Vista Home Premimum.  The system cannot find the built in web cam.  I get "unknown device" in the list of USB devices.   I have visited hundreds of forums, and there seems to be many problems with built in web cams on Toshiba laptops.  I don't even know what kind of cam it is, Chicony???

 

Help!!!   I have tried many things, deleting the camera assistant, reloading it, USB drivers, all kinds of things.  I am exasperated.   Does anyone know what these problems are that so many Toshiba laptops have????????

Member
sten79
Posts: 5

Re: L505-S5990 webcam is not working

i bought the l500 with windows 7 and got the exact same problem too mate, cant be arsed taking it back as we got some money knocked off it cos they didnt have the right laptop in so worried if i do ill end up with a cheaper one and tbh would rather just fix it now ive set it all up ??? someone must know somethign as it seems a common fault ???

Member
darcismith
Posts: 1

Re: L505-S5990 webcam is not working

hi i have the same problem. i was just wondering if you figured it out yet?

Member
cation007
Posts: 7

Re: L505-S5990 webcam is not working

I just bought S5990.

 

Webcam works. But doesnt focus. Image blurred and its dark even under ambient lighting.

 

Tried everything but could not fix it.

Member
mking
Posts: 4

Re: L505-S5990 webcam is not working

Haven't found anything yet.  It briefly started working on its own, but then the next time I rebooted, we were back to the error message.  So I know it CAN work, but there's just some problem.  I think it's a driver issue, and they probably need a new version for Windows 7.

 

If it's any consolation, you aren't missing much.  The webcam picture was unbelievably awful...a dark, grainy picture of some ugly mug...oh wait, that was me. :smileywink:

Member
Harv
Posts: 3

Re: L505-S5990 webcam is not working

I got the same problem. A brand new laptop that I got yesterday.. pretty annoying..

 

So .. there is no sollution to this??

 

 

Member
cation007
Posts: 7

Re: L505-S5990 webcam is not working

No solution. I just returned and got a brand new HP laptop.

 

HP rocks with webcams ...

Member
Harv
Posts: 3

Re: L505-S5990 webcam is not working

Have the same problem.. bought a L450 2 days ago.(Normally I use a mac, and btw.. its alooot better)

But this is how you can make it work. Turn off the firewall. Make sure its not on when you start the machine. Then the cam works.

 

Anyone having the same experience??

Regular Member
brunke
Posts: 9

Re: L505-S5990 webcam is not working

I am thinking that all the "updates", Windows and Toshiba, are the problems.  Especially the BIOS update.  The machine came with BIOS 1.x.  I updated to 1.4.  A friend has a similar laptop model with the original BIOS and the web cam works fine.  But I can't find an original BIOS to reload.

 

I think Toshiba knows about this problem, but is too busy with all the Windows 7 update stuff.

Member
bobatude
Posts: 1

Re: L505-S5990 webcam is not working

There is a protective plastic coating over the web cam / remove that and the miracle will happen / also there is a white thin bar on the extreme left hand side of the screen/take cursor to that and a menu will drop down first boxed icon will start the webcam / once started click on the camera to take picture or click on video camera to take vid / I hope this helps/ until I took my protective plastic off i was bummin

Member
NomadSoul
Posts: 3

Re: L505-S5990 webcam is not working

Hey I dont realize if this Model is 64bit or 32bit

 

and if this model if Toshiba Team could make a driver binarie for Linux

Member
athc23
Posts: 2

Re: L505-S5990 webcam is not working

I have the same exact problem, except that mine was working fine for the past couple of months that I've had this laptop.  Albeit, the quality isn't that great, but at least it worked.  But 5 minutes ago, I tried using gchat as I always do and it just decided to stop working.  Now I'm getting that usb code 43 as well.  The other detail to mention is that I have an L505-S5971.  I can't even check to see about my warranty because their site is down "until maintenance is completed."  Well that's great, thanks for being so particular about the date for that...

Member
ldonevan
Posts: 2

Re: L505-S5990 webcam is not working

I am also having the same problem

I have a a satellite L300-156 and the webcamera is not working

what is worse however is that every other second there is a little noise that goes off like I am plugging and unplugging a usb device and a little message appears at the bottom of the screen.... the noise is driving me insane

I am also in a foreign country at the momment so will be trying all attempts to fix it on my own as language is a huge problem

I cannot find any imaging devices or camera under the device manager

It used to work, literally used it less then a week ago and I can't explain why it has stopped and it has put a major damper on communicating with family over the holidays... not impressed

Member
mcroker
Posts: 1

Re: L505-S5990 webcam is not working

I had a similar problem (webcam worked for first 24hours and then started failing with code 43). I guess that this might have been due to a windows update downloaded automatically.

 

I resovled the problem by updating the bios with the latest available from toshiba (http://uk.computers.toshiba-europe.com/innovation/generic/SUPPORT_PORTAL)

 

Martin