Reply
Member
rookie06
Posts: 1

TV HELP!! 62HM84

My lamp on my tv went out - model 62HM84.  I ordered a replacement and installed it.  When I turn it on it makes a loud rapid clicking noise (sounds like coming from the lamp) and doesn't ever turn on.  According to the owners manual chart it says the lamp isn't working properly.  What else to try?  I'm fairly certain I installed it correctly as there's only 1 way it fits.  Surely a brand new lamp isn't bad?????  Lamp was ordered from www.projectorlampcenter.com. and I'm positive I have the correct one.  Any help is greatly appreciated!

Member
Hercules
Posts: 2

Re: TV HELP!! 62HM84

I have the same problem with my 52HM95 TV.I changed the lamp and also replaced the ballast for the lamp power. All fans are working , as they were before I replaced parts.The old lamp did not look blown.The power red light comes on then the green light blinks on and off like the troubleshooting guide says,up to 8 times to reset., thens turns off. Guide says to change lamp but no help.Lamp still not coming on. I have since found another fuse in the system other than the one at the power.board.mine is a 250V fuse located on opposite side of power board, kinda hard to notice if not known it was there. Mine is blown, yet still getting powerto ballast board but lamp will no come on.will change fuse to the correct size and see if that helps.i installed a lower 125V fuse I had but no help.What to do next?

Member
dan597
Posts: 1

Re: TV HELP!! 62HM84

Where and how hard is it to replace the ballast? I just replaced the buld for the 4th time in 7 years, not to bad i think.

It worked for about an hour, then the TV started blinking again as if the bulbed burnt out. I pulled the new bulb and there nothing wrong with it that I can see. I see other forum's talk about replacing the ballast, is it hard and or expensive? Don't want to drop a lot of money into a 7 year old TV, even though usually when I pit in a new bulb it looks great.

Member
fredfct51
Posts: 1

Re: TV HELP!! 62HM84

Have H62HM84 - almost 10 years old.  Replaced lamp after 6 years.  4 years into 2nd lamp got the red and green indication that lamp was not operating.  Bought new lamp from Toshiba.  Just put it in - same indications, no picture.  Plan to call local serviceman and get estimate.  Anticipate cost will make it not worth repairing.  Probably will try to return lamp to Toshiba for refund and go buy a new TV. Too bad - liked TV and stand.   Any suggestions before I go to the dump?