Reply
Member
elimaes12
Posts: 1

Toshiba Satellite A300-129 Crisis Recovery Mode Phoenix BIOS with USB drive

[ Edited ]

When flashing my BIOS back from v4.20 to a v3.90 I found on the net, everything went alright in windows, but as soon as I rebooted, the laptop showed the symptoms of a failed BIOS.

 

I'm now trying to repair the BIOS using the crisis recovery tool. I used the following procedure to create the USB stick and recover the BIOS

-Run the WINCRIS.Exe file in administrator and compatibility mode (Windows XP SP2)

 

-Select the USB drive (1GB Kingston), and format it with the tool

 

-Reinsert the drive and format again with the tool without restarting it to be sure that the disk is properly formatted

 

-Take the BL5S3D57.WPH file from the toshiba BIOS update and rename it to BIOS.WPH, and copy to the Crisdisk directory

 

-Copy the files BIOS.WPH (the one from toshiba I renamed), minidos.sys and winphlash16.exe to the drive in windows

-Take the drive out

 

-Plug battery out, plug AC out of laptop, hold the power button for a few seconds to make sure no remaining current is in the laptop

 

-Plug the USB Drive in

 

-Hold Fn+Esc in my case, this is the key combination where the laptop tries to read the USB drive the moment it boots up. It has something to do with enabling a boot block in the BIOS with that key combination.

 

-Plug AC in while still holding the F button

The F button does not nescessarily need to be held while plugging in AC, the laptop also tries to read from the drive if I hold it after plugging AC in, and before pushing the power button.

 

-Press the power button

I need to push the button twice, because the first time after plugging in AC the power button doesn't do a thing. When holding the power button for around 10 seconds after right after plugging AC in, the laptop boots sometimes, didn't find a pattern yet here.

The easy thing however is to just push the button 2 or 3 times, then it boots, and the booting procedure seems exactly the same as when holding the power button

 

-Wait for the LED to flash on the USB Drive. Very important: it seems to only flash ONCE for me, so it means it tries to access the drive, but I think it doesn't contain the right files or isn't formatted correctly. If I keep holding the F button while the laptop is on, the LED flashes once every 10-20 seconds.

 

From here on out the laptop is supposed to be reading the BIOS files from the USB drive, but apparently I'm doing something wrong. So here comes my question:

What could I be doing wrong in formatting the drive or writing the files to it?

Do I have the wrong CRISDISK? Is it normal that the files arent copied by CRISDISK to the USB Drive and that I have to do it myself?

Am I using the wrong WinPhlash? Or should I use the files that are supplied in the official BIOS rar from toshiba?

 

I have tried different versions of CRISDISK, different USB Drives (one 4GB would not be read by the broken laptop, and another 1GB would not be read by CRISDISK when trying to format the drive)

Tried different files on the USB Drive, tried bios.wph instead of capitals, tried BIOS.FD,...

 

I'm kind of running out of options here to try. Is there anyone who has experience with this recovery mode flashing that could tell me what I might be doing wrong? Or that has any suggestions on which other CRISDISK or toshiba updates to use?

 

Thanks anyways to people who read this and try to help!