Reply
Member
Posts: 1

L875D-S7332 keeps dropping wireless connection

HELP!!!

 

I have 4 Toshiba laptops that will not stay connected to the internet. They keep dropping the wireless. My latest one L875D-S7332 has Windows 8 which is the the biggest PITA yet.

 

All of them drop the internet though. I have reset the Yubi router, updated all of the drivers, have unchecked the shut the device down checkbox. Nothing works.

 

I am seeing this is almost a recall issue for Toshiba. I even called Toshiba and they had no help. They were going to escalate to Level 2 but I never received a response.

 

 

Anyone have any other thing I can try.

 

It is in device mgr and it says it is working fine.

 

Thanks

 

Jack

Occasional Advisor
Posts: 80

Re: L875D-S7332 keeps dropping wireless connection

Check this post and see if any of the options in the second post possibly help. http://forums.toshiba.com/t5/Networking-Wi-Fi/WiFi-issue-Satellite-S855-S5378/td-p/377965
Member
Posts: 4

SOLUTION! Re: L875D-S7332 keeps dropping wireless connection

It is the power saver setting. I realize the original poster may have already given up or moved on but for the benefit of others you want to make sure your power setting is on high performance. The easiest way to do this is to click the battery icon at the bottom right of your screen. Go into the settings or advanced settings and simply change to high performance. Yes, it will cause your battery to have less life but you won't be tempted to throw your laptop out the window for dropping your wifi continuously. 

Member
Posts: 2

Re: SOLUTION! Re: L875D-S7332 keeps dropping wireless connection

I was having the same problem with my older laptop & thought is was that I had changed internet providers & had inferior service to what I was used to.  But I just moved to a new home & changed providers again & it got ridiculous, refreshing & reloading every page literally every few seconds.  I had my power settings on a custom plan, but changed them to High Performance about an hour ago & haven't had to refresh once....  Seems to be the fix!!  Thanks