Num Lock Turning Off

Reply
Member
Posts: 6
Accepted Solution

Num Lock Turning Off

For some reason recently, when I shutdown my system, the next time I start up Num Lock has turned off. I always have it on and didn't realize immediatly what was  happening when I typed in my password, which includes numbers, and have it rejected.  Yes my laptop, A505 has the light but I never really had to look at it before.

Anyone have any idea why this is getting turned off all of a sudden?


Accepted Solutions
Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off

These two Microsoft articles apply to 64-bit Windows Vista as well as Windows XP.

 

   How to Set the NUM LOCK State at Logon in Windows XP

 

   How do I enable the NUM LOCK key for the logon screen?

 

The value InitialKeyboardIndicators in the following registry key may now be set to the string 2147483648, which is the decimal equivalent of 0x80000000 (zero with a leading bit). It can be changed to 2 by setting the decimal string to 2147483650, which is 0x80000002. (I understand that the presence of that leading bit causes a BIOS setting of On to override a registry setting of Off.)

 

   HKEY_USERS\.Default\Control Panel\Keyboard

 

Take your time. Be sure to export registry keys before changing them.

 

Let us know how it goes.

-Jerry
Channel 9

View solution in original post

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off


..why does setting account password turn it off...?

You're saying this?

 

When you have a blank login password and set numlock on, it is still on when you reboot.

 

When you assign a non-blank login password and set numlock on, it gets turned off during a reboot.

-Jerry
Channel 9

View solution in original post


All Replies
Regular Advisor
Posts: 3,300

Re: Num Lock Turning Off

Something has changed in you BIOS settings.  You may need to go in and reset to 'always on' status and reboot. TRY THIS PLEASE: 

To turn the NumLock key on:

Go to Start, then select Run.

In the "Open" box in the Run window, type "sysedit" (without the quotes). Click on OK.

This command opens the System Editor, the utility that helps you edit several important system-configuration files, including autoexec.bat, win.ini, system.ini and config.sys.

When the System Editor finishes loading, each one of these files will be contained in its own window.

Click on the name bar of the config.sys window to activate it.

In the text portion of the config.sys window type:

Numlock=ON

Save, exit the System Editor and reboot.

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off

I believe these Toshiba machines are configured so that the numlock state is remembered during a reboot. Is that okay now?

 

Which A505?

-Jerry
Channel 9
Member
Posts: 6

Re: Num Lock Turning Off

when I enter "sysedit" in the Run box I get a message that Windows could not find it.

My laptop is A505-S6960, 64bit, Windows 7 Home Premium

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off

[ Edited ]

 

Satellite A505-S6960 

 


when I enter "sysedit" in the Run box I get a message that Windows could not find it.


That file is for DOS-based Windows (3.x/95/98/Me). In any case, it's a 16-bit program that your 64-bit Windows could not even execute.

 

 

Check the BIOS for a numlock setting.

 

   Start > All Programs > Toshiba > Utilities > HWSetup

 

 

Are you comfortable doing registry surgery?

-Jerry
Channel 9
Member
Posts: 6

Re: Num Lock Turning Off

There is no Numlock setting in HWSetup!  Yes I'm fairly comfortable making changes to registry.

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off

These two Microsoft articles apply to 64-bit Windows Vista as well as Windows XP.

 

   How to Set the NUM LOCK State at Logon in Windows XP

 

   How do I enable the NUM LOCK key for the logon screen?

 

The value InitialKeyboardIndicators in the following registry key may now be set to the string 2147483648, which is the decimal equivalent of 0x80000000 (zero with a leading bit). It can be changed to 2 by setting the decimal string to 2147483650, which is 0x80000002. (I understand that the presence of that leading bit causes a BIOS setting of On to override a registry setting of Off.)

 

   HKEY_USERS\.Default\Control Panel\Keyboard

 

Take your time. Be sure to export registry keys before changing them.

 

Let us know how it goes.

-Jerry
Channel 9
Member
Posts: 6

Re: Num Lock Turning Off

Changing the value in the Registry worked.  BUT when I entered my account password and hit Enter it turned off again.  Then it occured to me that I just created this password a couple of days ago since I've been taking my laptop to work.  So I assumed that was what was turning off Numlock.  To verify I removed the password, rebooted, and viola!  Back to normal Numlock comes on and stays on.  So the question is why does setting account password turn it off...some kind of security protection?

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off


..why does setting account password turn it off...?

You're saying this?

 

When you have a blank login password and set numlock on, it is still on when you reboot.

 

When you assign a non-blank login password and set numlock on, it gets turned off during a reboot.

-Jerry
Channel 9
Member
Posts: 6

Re: Num Lock Turning Off

Thanks for your help Jerry.

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off

Windows is not supposed to work that way, Gene.

-Jerry
Channel 9
Member
Posts: 1

Re: Num Lock Turning Off

Thanks Jerry for the solution.  It worked for me here!  Thanks for translating the decimal number in the Regedit screen to the underlying hex number which we humans can then instantly see its meaning.  I mean the decimal 2147483648 looked like gobbledegook until I had the patience to read this thread carefully and get to this specific answer to GeneT.

 

This problem came up with a brand new Toshiba Satellite L50-B I'm setting up for one of my customers.  I first experienced the inconvenience as GeneT did when I tried to login by touch typing and not looking at the screen and getting a password error.  Then I tried again and noted that as I used the numeric keypad to type in the numbers of the password nothing was being typed in!  No wonder the password was wrong!  Then I looked closely and noted that the little green light of the NUM LOCK  key was not on.  On further restarts I noted that the NUM LOCK light came on during boot, went out and went on and finally went out when Win8.1 and then updated to Win 10 would stay out.  You had to press the NUM LOCK key to turn it on.  Further the BIOS screen of this machine had no option to control the default behaviour of the NUM LOCK key.

 

I think Toshiba should ship future issues of laptops with a customise registry so that the default key data is 2 rather than zero.

 

It was me who clicked the Kudos button for you Jerry!  Cat Happy

Posts: 47,962
Topics: 85
Kudos: 9,136
Solutions: 3,232
Registered: ‎12-04-2008

Re: Num Lock Turning Off


Win8.1 and then updated to Win 10


And thanks for cofirming that Windows 8/10 still check this registry setting.

-Jerry
Channel 9