Reply
Member
neonfrog
Posts: 5

Alternate Characters Toggle?

New Satellite L350 running Windows Vista

(not liking keyboard layout at all, but that's a different story)

 

I'm looking for instructions on how to toggle on and off the alternate characters.  Somehow I am toggling them on without realizing it until I go to use a " or < , etc. and I get the (red) alternate character instead.

 

I code in html so this is really frustrating.  Haven't been able to find out how this happens or how to fix via searches (wrong terms perhaps) so any help most appreciated.

 

Shelley

Regular Advisor
Defender
Posts: 3,300

Re: Alternate Characters Toggle?

Most immediate action is to consult your Toshiba Guide on this concern.  Unknown how you have set the html factor key setup.  Here is an option:  use the START SEARCH and type in character map, when achieved you can reset the keyboard layout to you personal desires.

Member
neonfrog
Posts: 5

Re: Alternate Characters Toggle?

I'll pull out the manual and see what I can find - it was interesting that I couldn't really locate much if any info googling. However, one result came with the suggestion that I can be accidently hitting the FN key and to switch off the alt char (ones in red on keyboard) I just have to hit the FN key again.  I will be giving that a try today.

 

With respect to the html - it's just that when I'm coding and I manage to accidently toggle these alt. char's, I can no longer work.  I have to use a lot of " " <> among other characters so the only way I've been able to change it back was to close down everything and restart to get back to the default setting.  I have already checked keyboard config for lang settings, etc.  It appears to be a sequence of keys that I'm hitting (which is happening because this keyboard's layout is a bit awkward).  Anyway, shutting down the numerous files I have open for work and restarting is a pain :-) but if this FN key solution works, I'll post the result.

 

thanks for your time.

Occasional Advisor
Techman
Posts: 1,169

Re: Alternate Characters Toggle?

On US units we don't have those red keys, so I don't know...

 

But try Fn+F10, or Fn+F11, or Fn+F12.  Each of those have a status light, just like the caps lock key does.  So look for the status light, and look for an icon ont he key that matches.

This signature left intentionally blank.
Regular Advisor
Defender
Posts: 3,300

Re: Alternate Characters Toggle?

Fn is a good feature, and use of the character map will assist you.  Glad the data was able to point you in the right direction.

Member
kengra
Posts: 1

Re: Alternate Characters Toggle?

I have had the same problem over and over...  I have struggled with this one... and today I just figured it out...  how to turn off the alternate characters.  I still don't know what I do to turn them on - they just start all of a sudden in mid typing sometimes.  Obviously I hit some combination of keys that does this.  It is frustrating because it affects my ? key and others that you will use on a regular basis and then you cannot ask the question with the proper punctuation.

 

Here is what to do...

 

Locate your "Language Bar" - mine sits in my Icon Tray.  This is the Bar that allows you to change from an English to French keyboard and other options.  There will be an Options option or a drop down.  The quickest way is to hit the drop down arrow and then select "Restore Defaults".  This is an immediate fix and does not require a restart.

 

Hope this helps!

Regular Advisor
Defender
Posts: 3,300

Re: Alternate Characters Toggle?

good information kengra.

Neonfrog..since you are doing coding, see what an external KB will produce for you.  Worth a try.

Member
neonfrog
Posts: 5

Re: Alternate Characters Toggle?

thanks everyone for the replies - I've been 'away' from my regular job covering for someone who is on medical leave so I haven't had much of an opportunity to try out the different suggestions.  I've also somehow gotten better at not accidently hitting the keys that were causing the problem to begin with (rofl) - just getting used to the keyboard layout has helped.

 

regardless, the feedback has been great and I'm very appreciative.  I'm printing off the replies to have handy for the next time I run into this problem (I don't know how it got started in the first place!)  I'll also look for an eg of the layout of the keyboard with the alt char designations  (ie the ~ key has | # \  shown in red besides the ~ and` in blue.  It's the characters noted in red that I've been referring to as alt char. and I'm not sure what sequence of keys I have been hitting that have launched these instead of the regular characters).

 

so thanks again and I'll post again with any results

 

cheers Shelley

Regular Advisor
Defender
Posts: 3,300

Re: Alternate Characters Toggle?

Good luck neonfrog in all your endeavors.  Closure here.

Member
Gruzbad
Posts: 2

Re: Alternate Characters Toggle?

[ Edited ]

I have a solution for you Neonfrog.

 

The default keyboard command is "ctrl-shift" to switch between languages.

You can disable this by going into your control panel, then to Regional and Language Options.

Once there, go to Keyboards and Languages tab, then click on "Change Keyboards"

You'll see the "Text Services and Input Languages" screen pop up.

Click on the Advanced Key Settings tab

Highlight "Between input languages" and click the "Change Key Sequence..." button.

The column on the right, called "Switch Keyboard Layout" is what is actually changing your language setting.

Change that to whatever you want and you're good to go! 

 

I leave mine on "Not Assigned" so I don't have any accidents :smileyhappy:

Member
neonfrog
Posts: 5

Re: Alternate Characters Toggle?

Dear Gruzbad

 

thanks!  I will give that a try.  What I have done is put the keyboard icon in my botton nav tray so that when I accidently switch languages I just click on it and put it back on US.  So far that has worked well and certainly is a lot less frustrating  :-)  The worst times were when I was coding and then of course could not use any of the symbols associated with html.

 

many thanks to everyone for their input - it has been exceedingly helpful  :-)

 

ciao!

Member
Gruzbad
Posts: 2

Re: Alternate Characters Toggle?

No problem Neonfrog. You'll see that you can disable the Alternate characters completely if you like, or change the key stroke combination to something else. 

Member
trikerike
Posts: 1

Re: Alternate Characters Toggle?

A-h-h-h-h!  At last, at last.  Thanks Gruzbad for this answer.  Of course the manual was no help at all, nor my previous four hours of searching the net.

Member
CaLEAFornia
Posts: 1

Re: Alternate Characters Toggle?

I had the same problem with the characters changing on me.

The 'control panel' answer worked.... clock, language and region....change keyboards or other input methods, then

click change keyboards and uncheck languages you don't need....I'm in Canada and had the english set-up but french Canada [and something else] and unchecked them.

Now everything's good, Cheers!