Reply
Member
wingnut
Posts: 8
Accepted Solution

Windows 7 SP1 now Battery Icon gone

Ok we have Windows 7 Professional and after installing I no longer have my battery icon nor can I turn on the power in system tray as it is greyed out.  Please help.  We have satellite a505-s6025

Ace Advisor
Jerry_Lippey
Posts: 38,773

Re: Windows 7 SP1 now Battery Icon gone

 

Satellite A505-S6025 

 


..nor can I turn on the power in system tray as it is greyed out. 

Right click the following item under Batteries in Device Manager, click Uninstall, and confirm that.

 

   Microsoft ACPI-Compliant Control Method Battery

 

Restart Windows.

-Jerry
Member
wingnut
Posts: 8

Re: Windows 7 SP1 now Battery Icon gone

Jerry thank you for the help but it's still greyed out as a option after deleting.  What should the battery under devices be listed as?

Ace Advisor
Jerry_Lippey
Posts: 38,773

Re: Windows 7 SP1 now Battery Icon gone


What should the battery under devices be listed as?

Not clear whether you did anything. If not...

 

1. Open Device Manager (devmgmt.msc).

 

2. Expand Batteries.

 

3. Right-click Microsoft ACPI-Compliant Control Method Battery.

 

4. Click Uninstall in the pop-up menu.

 

5. Confirm the Uninstall.

 

6. Restart Windows.

 

 

If that doesn't free up the power icon, try this. Download the attached ZIP file and decompress it to this.

 

   Enable_Power_Notification_Icon.reg

 

Double-click that file in Windows Explorer and confirm that you wish to modify the registry. Restart Windows.

-Jerry
Member
wingnut
Posts: 8

Re: Windows 7 SP1 now Battery Icon gone

I have deleted ACPI but when it reboots it shows back in the devices.  I have also ran zip file you posted.  This did not correct.  Any other suggestions?

Member
wingnut
Posts: 8

Re: Windows 7 SP1 now Battery Icon gone

Jerry we also have an identical laptop and it doesn't have this issue.  Any way to correct by using info from the other laptop?

Ace Advisor
Jerry_Lippey
Posts: 38,773

Re: Windows 7 SP1 now Battery Icon gone

I don't know how the other laptop might help, but it's nice to know an identical machine is nearby.

 

Let's see if resetting the BIOS changes anything. With the battery and AC adapter removed, close the Power switch for ten seconds. Re-attach those, press the Power button to turn the computer on, and then immediately press the F2 key while the Toshiba logo is displayed. Press F9 to restore the BIOS default settings, press F10, and then select Yes (Exit Saving Changes). The computer will restart.

-Jerry
Occasional Advisor
TheWarrior
Posts: 153

Re: Windows 7 SP1 now Battery Icon gone

Lots of solutions that worked here

Ace Advisor
Jerry_Lippey
Posts: 38,773

Re: Windows 7 SP1 now Battery Icon gone

And if resetting the BIOS doesn't work, try executing the Microsoft file attached. After decompressing, it's named MicrosoftFixit50229.msi.

-Jerry
Member
wingnut
Posts: 8

Re: Windows 7 SP1 now Battery Icon gone

Jerry I wanted to let you know that I did do a Norton Power Eraser and it found a string in current user that was a "hide icons".  It deleted it and now I have my icon back.  Thank you for your offers of help.

Ace Advisor
Jerry_Lippey
Posts: 38,773

Re: Windows 7 SP1 now Battery Icon gone


I did do a Norton Power Eraser and it found a string in current user that was a "hide icons".  It deleted it and now I have my icon back. 

Really? I never suspected a virus. Thanks for letting us know.

 

In that case, I wouldn't be surprised to encounter other anomalies.

-Jerry