Webcam driver L645D-S4040 HELP!

Posts: 1

Webcam driver L645D-S4040 HELP!

Webcam suddenly stopped working seems like the application and driver were uninstalled. Tried complete  computer recovery didn't work, I think I just need to download the driver and application again. I have tried to download the application several times but can't get it to work.. Anyone have any suggestions? Please help!!! 

All Replies
Posts: 44,688
Topics: 77
Kudos: 7,219
Solutions: 2,992
Registered: ‎12-04-2008

Re: Webcam driver HELP!


Satellite L645D-S4040 


Tried complete  computer recovery didn't work,

Restoring the hard disk to its original out-of-the-box contents using Toshiba recovery media is the gold-standard way of reinstalling the driver.


If that doesn't work, there's a hardware malfunction.

Channel 9
Posts: 1

Re: Webcam driver HELP!

I have the same problem with my L645D-S4030.  The webcam app file will not reinstall.  Seems to extract but the installer won't run to finish the job.

Posts: 2

Webcam driver HELP!!



I´m kinda the same situation, I have  Satellite L645D-S406, windows7 and the internal webcam stopped working one day, as well as external, it does not even have 4 months used. No matter what webcam I connect, Genius, Treck, etc, the laptop can´t turn them on, I can see the webcam in device manager}imaging devices but when I plug the camera in any usb port, the light on the webcams does not come up, the cams are ok cause they work in other machines.

I tried reinstalling the toshiba webcam application for windows 7 in the toshiba website but that did not help, I also uninstalled all usb ports in device manage, and updated the usb drivers but issue persists. If I connect the Genius webcam I get: Error 80040154: cannot create video capture filter} and the AMCAP thing comes up empty. Is there any other options other than the system restore?

I cannot start the internal webcam or use external ones, in device manager I get ¨there is no HI-SPEED host controllers installed on this computer¨, is it because the USB composite device is set as full speed instead of high speed, is that related to the webcam thing issue?


Thanks help appreciated