Satellite A100 (PSAA8E-15T043IT) and Windows 7: help me!

Posts: 2

Satellite A100 (PSAA8E-15T043IT) and Windows 7: help me!

Dear Friends,

I'm new in this forum, and I hope you can help me.


I have installed Windows 7 pro on my laptop Satellite A100 (PSAA8E-15T043IT) without problems during install.

After completition, I found thhat there are two device not installed because they are without missing.


The ID Manufactured of the 2 device are:









I do not found any driver on Toshiba support for this device, so I ask you if you can help me or suggest what t do.


Best Regards


Luca from Italy

All Replies
Posts: 45,075
Topics: 79
Kudos: 7,567
Solutions: 3,025
Registered: ‎12-04-2008

Re: Satellite A100 (PSAA8E-15T043IT) and Windows 7: help me!

I believe the first device is the TI card reader. There's no Windows 7 driver for that, but the Vista driver usually works.


Maybe you installed 32-bit Windows 7.


   Texas Instruments Flash Media Driver for Windows Vista 32 Bit,, 09/07/07


Probably best to post in the European forums.


   Toshiba Support Forums in Europe

Channel 9
Posts: 2

Re: Satellite A100 (PSAA8E-15T043IT) and Windows 7: help me!

Hi, thanks!

I fixed the problem very easy! Looking on Toshiba Support for Windows 7 I download the file called TSI4WIN7.EXE, install it and it download the correct drivers. Now everithing is OK.


Best Regards



Frequent Advisor
Posts: 8,197

Re: Satellite A100 (PSAA8E-15T043IT) and Windows 7: help me!

Yep, Toshiba's Software Installer works like charm for most models in this situation.  Glad you got it straightened out.


If you don't post your COMPLETE model number it's very difficult to assist you. Please try to post in complete sentences with punctuation, capitals, and correct spelling. Toshiba does NOT provide any direct support in these forums. All support is User to User in their spare time.