Reply
Member
DrElch
Posts: 2

Portege Z830 - Can't update from BIOS 1.40 to 1.60

Hi

I've bought a Portege Z830 PT225A-00400G in New Zealand.

In the meantime I have reinstalled windows 7 professional from a clean source.

When I try to update the BIOS to the latest 160 version I always get the error message: "This computer is not supported".

A look at msinfo32 revealed the following BIOS version:

BIOS Version/Date TOSHIBA Version 1.40, 9/11/2011


is there a way to update to 1.60 anyway? ALl the upgrade packages I find are for 1.20 or 1.30

 

Cheers,

Mike

Moderator
Peter
Posts: 16,495

Re: Portege Z830 - Can't update from BIOS 1.40 to 1.60

Did you find that BIOS download on this site? This site only support the US region. The models are actually different. You should contact Toshiba support in your region.

- Peter
Member
DrElch
Posts: 2

Re: Portege Z830 - Can't update from BIOS 1.40 to 1.60

I have tried several BIOS downloads from US and NZ Toshiba support pages and none of them worked.

 

However, I had a different issue with my notebook which led to a replacement of the machine. The new one came with 1.60 straight away.

 

Peter,

I have realized that the models differ in different areas in terms of part numbers. I have got a Z830-S8301 with Part No. PT225A-00400G which is sold as a PT225U-004004 in the US.

A look at the specs list revealed that both models have got identical features.

Just out of curiousity, do you know if there are differences or are both models in fact identical?

Moderator
Peter
Posts: 16,495

Re: Portege Z830 - Can't update from BIOS 1.40 to 1.60

The regions operate separately, so I actually don't know anything about the NZ model at all. However, I do know that if the models seem similar and specs match, most drivers usually work despite not being officially supported. I don't know about the BIOS, however.

- Peter
Member
redmongoose
Posts: 1

Re: Portege Z830 - Can't update from BIOS 1.40 to 1.60

Hey DrElch

 

In order to update the bios on a clean install of windows 7 (non toshiba image) you will need to install the following 2 drivers from the support page:

- chip set utility

- value added package

Once you have installed both and restarted you will be able to update the bios - no more noisy fan !!