Reply
Member
connieh1994
Posts: 2

Satellite C655D-S5138 does not charge when plugged in

This laptop is only about 5 months old and the other day it was working perfectly fine then i noticed that it was not charging even though it was plugged in so i turned it off took out the battery, called tech support (not a help at all) and basically tried everything. My laptop doesnt even turn on anymore because theres no battery in it. SOMEONE HELP

Member
Savvy
Posts: 2

Re: Satellite C655D-S5138 does not charge when plugged in

Heya. What you've described is supposedly a common problem in all toshibas. Mine is three years old and it happened for the first time a year ago, and now it's happening again.

 

The ac jack in the computer isn't soldered to the motherboard, so it shifts and moves further into the computer or something like that. I fixed it the first time because I had a warranty, but now that my warranty's out, I don't think I'm going to get it fixed again, especially since they don't seem to solder a new jack to the motherboard, so the same problem will just happen again eventually :/ 

Member
connieh1994
Posts: 2

Re: Satellite C655D-S5138 does not charge when plugged in

how did you fix it?

Member
beckys01
Posts: 3

Re: Satellite C655D-S5138 does not charge when plugged in

That's what I would like to know too , please. I'm having the same issue with my L650 and Im sending it in for repairs and I've had it since Feb 2011 but it does seem an ongoing issue with Toshiba Laptops. Not good.

Member
wallyag
Posts: 3

Re: Satellite C655D-S5138 does not charge when plugged in

I have a Satellite L555d with similar issues. I first replaced the power adapter and the computer was able to turn on whereas it wouldn't before so I figured that was the problem. Then I noticed the battery icon said "power connected battery not charging" so I watched the battery go to zero, computer starts beeping and eventually shut down. I tried running the laptop with battery out and just power adapter but no luck, would not turn on. I then bought a new battery figuring it was the battery but with new battery installed the laptop ran until the battery went to zero and same message "power connected battery not charging". When I unplug and plug the cord into the socket the charge light goes on for a few seconds and then shuts off. The socket is not loose as I gave it to a computer tech to fix and he says that changing out the socket might or might not fix the problem. Has anyone else had a similar problem and how was it resolved. The laptop is about 14 months old and if its the motherboard I doubt I would buy another Toshiba product again laptop, flatscreen or whatever. 

Member
buzlight
Posts: 1

Re: Satellite C655D-S5138 does not charge when plugged in

Hi,

Got same problem with Satellite L40-139. I have 2 adapters and both test OK with a multimeter on volts range. When previously had Vista installed a message at bottom of screen read: "Plugged in but not charging". When using it either with or without the battery inserted it powers up from the mains/charger adapter. So I assume that nothing is unsoldered internally via the jack plug on the motherboard. When the machine is unbooted and the jack repeatedly plugged in and out, the laptop charger battery indicator comes on orange then goes off after a couple of seconds.

This sounds expensive but I have already ordered a replacement battery in desparation. Please help!

 

Dr P Straw.

Member
SuzanR
Posts: 3

Re: Satellite C655D-S5138 does not charge when plugged in

Hello,

 

I just posted an email w/the same topic. If your issue is the same as mine, all you have to do is to take the battery out and re-seat it and it will start charging again. My Re line is: Satellite C655-S6058 by SuzanR. That doesn't fix your problem though and I'm trying to get a resolution w/mine as well.

 

SuzanR

Member
cfiiman
Posts: 1

Re: Satellite C655D-S5138 does not charge when plugged in

[ Edited ]

Susan THANK YOU SO MUCH!!!!  The battery recent worked like magic for me, I never even register like this on these kinds of forums but wanted to b/c thanks to you I didn't take my whole machine apart.  If anyone is having this problem reset the battery!!!!!!!!  Thanks again Susan!