Reply
Member
meixing
Posts: 1

Brand new Satellite C655 : Plugged in, charging but 0% charge

I just got my toshiba laptop today and it works great ... when it's plugged in xD . As soon as the ac adaptor is disconnected it dies.

When I first connect the battery, it will show the battery icon filling up (animated) but then after about 10 seconds, it goes back to an image of a battery (almost empty) and the coord (still saying plugged in, charging) but after 2 hours, it still is 0% and won't work unless it's plugged in.

I tried a couple solutions - I uninstalled the Microsoft ACPI - Compliant Control battery and made sure it was updated, and it has the same result as above.

Then I tried the other solution I read here about disconnecting the battery and wires and holding down the power button for 30 seconds and that didn't work either.

 

Are there any other solutions I should try? It's a brand new computer, straight from the box. But apparently when I tried to call customer support, my complimentary phone support time period is over.

 

PLEASE HELP. Thanks in advance!

Member
rpvianna
Posts: 1

Re: Brand new Satellite C655 : Plugged in, charging but 0% charge

Hello,

 

I have the same problem with my Satellite A665 and I did the exact same things, but nothing happened. I already searched in other forums, but the only solution left is to send it to repair.

 

I hopping the Toshiba's support look at this Post and tell us a solution...

Member
yousefomar
Posts: 2

Re: Brand new Satellite C655 : Plugged in, charging but 0% charge

Hello Gents,

 

I've just received my C655-S5505 yesterday and I got the same problem !! 

 

please let us know if you have any other suggestion then listed above

 

regards

Member
yousefomar
Posts: 2

Re: Brand new Satellite C655 : Plugged in, charging but 0% charge

[ Edited ]

My problem is solved by one these things I did together in the following order:

 - Opened Device manager and Uninstalled "MS ACPI-Compliant Control Method" under Batteries. closed device manager (did NOT scan for hardware changes)

 - installed latest windows updates

 - shutdown the system, removed battery and cord, pressed power button for 30 sec

 - connected battery and power and turned on the laptop and the battery started charging

 

try to follow exact step and good luck

 

Regards

Member
Laptop25
Posts: 2

Re: Brand new Satellite C655 : Plugged in, charging but 0% charge

I was interested in the C655-S5505, but read a few reviews that said people had battery problem of not accepting a charge.   Did yours get running? and R U happy with it?

Member
Sokolov
Posts: 2

Re: Brand new Satellite C655 : Plugged in, charging but 0% charge

I am having the same problem.  Upon insertion, the battery icon will show the charging animation for a few seconds, then stop and keep at 0% indefinitely.

Member
Sokolov
Posts: 2

Re: Brand new Satellite C655 : Plugged in, charging but 0% charge

I tried this, no change.