Reply
Member
maf1
Posts: 1

Satellite L750 sound problem

 

Hi,

I own an L750/L755 tohsiba laptop, i suddenly got problems with the sound about 2 months ago. When i play music the sound is okay for 2 minutes then it goes off. The sound is okay when i use earphones. I sent the laptop back to the company where i purchased it from and they informed me they sent it back to toshiba who fixed new speakers. Apparently it was a hard ware problem. However on receiving it yesterday the coputer still has the same problem, i can play a music for 2 mins and then its off. Connecting it to the speakers or earphones it works fine.

 

Please help.

 

maf1

Moderator
Peter
Posts: 17,160

Re: Satellite L750 sound problem

Can you check the laptop's full model and part numbers from the label on the bottom? Don't include the serial number.

- Peter
Member
leon25
Posts: 2

Re: Satellite L750 sound problem

[ Edited ]

Hi

 

I have a similar problem. I own toshiba laptop  L750D-1D3 (PSK34E) about 18 months and everything worked fine, but 20 days ago there was a problem with the sound. When I play music or video sound is fine sometimes 10 minutes sometimes 15 but it happens that just disappears and when I stop music or video and play again works for some time 5-10 minutes and then go off again. I tried to install the drivers again but it does not solve the problem.  I use windows 7 64-bit OS.

How can solve this problem 

 

please help

 

 leon25

 

 

Member
kich65
Posts: 1

Re: Satellite L750 sound problem

My l750 had the same sound problem as the many posts on this site.  February 2013, after much frustration, I sent the compurer back to Toshiba.  It was repaired and returned with new speakers and motherboard.  It worked fine till about 2 months ago and then the same problem occured.  Plugging in headphones to the speaker jack brings the sound pack for about 30 seconds.  This is the second Toshiba to have problems.  On the first one the DDR ram chips burned out one month after the warranty ran out.  I have set the computer back which didn't help. Tried windows 8.1, didn't help.  Used recovery disks and reinstalled everything, didn't help. Called Toshiba,