Reply
Member
hkhouli
Posts: 4

No sound when connecting Laptop to TV

Hey guys,

 

When I connect my laptop to my TV via HDMI, there is no sound output coming from the TV, however there is sound coming from the laptop. I have updated my sound drivers however it still does not work.

 

My laptop:

Toshiba Satellite L655-1HC

Short Model No.: PSK1JE

Windows 7 Ultimate (x64 bit)

 

I have updated my drivers from this page : http://gulf.computers.toshiba-europe.com/innovation/download_drivers_bios.jsp?LNG=13&service=AE

 

I have scoured the internet for a solution but so far I haven't found one. Restoring factory settings is not an option with me. 

 

Under the 'Playback' section of the sound menu, there are two options listed when there is no output to the TV which are:

 

Sound

Conexant CX20671 SmartAudio HD

Default device

 

HDMI Output

Conexant Audio Driver For AMD HDMI Codec

Not plugged in

 

I do however, have the HDMI cable plugged in. Both devices are enabled. However when I switch output to the TV, the 'HDMI Output' option disappears completely. Even when Show disabled/Disconnected devices' are both checked. I have attached some screenshots for Reference.

 

Thanks,

Hasan

Ace Advisor
Jerry_Lippey
Posts: 39,080

Re: No sound when connecting Laptop to TV

[ Edited ]

 

Satellite L655-1HC (PSK1JE-0GT00XAR)

 

 

I had to set HDMI as the default output on the Playback tab to make it work here.

 

Yours says Not plugged in. Maybe you should try another cable.

 

Also, open Device Manager (devmgmt.msc), expand Sound, video and game controllers, and see if it's there. If so, double-click the device and tell us what Device status has.

 

This is your sound driver.

 

   Conexant Sound Driver for Windows 7 - 64 Bit, 4.119.0.61, 10/01/11

-Jerry
Member
hkhouli
Posts: 4

Re: No sound when connecting Laptop to TV

Thanks for the reply.

 

I dont think its the cable because I use the same one with my PlayStation 3 system.

 

I cant set the device to default. When I right click on it, those options are greyed (refer to the pictures I have attached in my first post). 

 

The device is there in device management and the status is :"This device is working properly."

 

The sound drivers were already updated to the same version but I did yours anyway and nothing has changed.

I dont know if this is relevant, but in some threads I read through stated that it might have something to do with Intel chipset drivers or something like that. Under Unkown devices in Device Management there is one that is Unkown but its location is "on Intel(R) HM55 Express Chipset LPC Interface Controller - 3B09". When I click on Update Driver as per Windows suggestion, it returns me with a message "Windows was Unable to Install your Unkown Device" . I really have no clue what it is either or if it is relevant. If its not, dont worry about it, it is a thread for another time.

Ace Advisor
Jerry_Lippey
Posts: 39,080

Re: No sound when connecting Laptop to TV

Can't hurt to run this Microsoft Fix it.

 

   Hardware devices are not working or are not detected in Windows

 


Under Unkown devices in Device Management there is one that is Unkown but its location is "on Intel(R) HM55 Express Chipset LPC Interface Controller - 3B09".


Maybe you can identify that device using its Hardware IDs.

 

   How to identify an unknown device (e.g. Wireless LAN module)?

-Jerry
Member
hkhouli
Posts: 4

Re: No sound when connecting Laptop to TV

So I ran the fix it which didnt help at all. Then I tried to identify the hardware which took me to this page.:

 

http://www.pcidatabase.com/vendor_details.php?id=280

 

Not sure which one it is though.

 

PNP Device ID: ACPI\TOS6205\4&4A257CF&0

 

Seems this guy also had the same device: http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=62003

 

 

Ace Advisor
Jerry_Lippey
Posts: 39,080

Re: No sound when connecting Laptop to TV


when I switch output to the TV, the 'HDMI Output' option disappears completely


I'm still suspicious of that Not plugged in message. Could be hardware, maybe in the TV.

 

One way to eliminate software is to restore the hard disk to its original out-of-the-box contents using Toshiba recovery media.

 

That's not as bad as it sounds if you create a backup of the the entire disk and restore it later.

 

   Back up your programs, system settings, and files

 

   How to Create a System Image Backup in Windows 7

 

   Restore your computer from a system image backup

 

   How to Do a System Image Recovery in Windows 7

-Jerry
Member
hkhouli
Posts: 4

Re: No sound when connecting Laptop to TV

Well theres no need for that. I don't know what happened, but I got the sound to work in the TV. Must have been the Fix It tool, but I dont remember that it did anything. 

 

Thanks for your help!

Ace Advisor
Jerry_Lippey
Posts: 39,080

Re: No sound when connecting Laptop to TV

Good for you!

-Jerry
Member
amk4609
Posts: 6

Re: No sound when connecting Laptop to TV

Hello -- I am having a similar problem, when i connect my Satelite L745-S4210 to the TV i have no sound coming through. other posts i have read say that under the control panel-hardware and sound-manage devices, I should be able to "turn on" HDMI - but all i have in there is Speakers.  Please let me know what you recommend

Super Advisor
miker643
Posts: 3,438

Re: No sound when connecting Laptop to TV

[ Edited ]

Satellite L745-S4210 Specifications

Satellite L745-S4210 Downloads

 

 

Right click on the speaker icon in the system tray at the bottom right of your screen, click on 'Playback devices', click on a blank part of the 'Playback' tab's window, put a check mark on both 'Show Disabled Devices' and 'Show Disconnected Devices', right click on your HDMI device, click 'enable'. Right click again on your HDMI device, click 'Set as Default Device'

 

Let us know what happens. Good luck.

 

Mike

Member
amk4609
Posts: 6

Re: No sound when connecting Laptop to TV

Even when i right click and have "disabled devices" checked, the only thing there is still "speakers".  (no HDMI) 

 

is there something I am supposed to do with those links to download?

Thanks so much!!

Super Advisor
miker643
Posts: 3,438

Re: No sound when connecting Laptop to TV

Try a proper system reset and see if this helps bring the HDMI audio back. Power off your system, unplug everything including the AC, remove the battery, press and hold down the power on button for 30 seconds, replace battery and AC, power on, when you see the Toshiba logo press the 'F2' key to enter BIOS Setup, in setup press 'F9' to load setup defaults, press 'F10' to save and exit, boot into Windows, and right click on your speaker icon again, click on 'Playback devices', do you see the HDMI audio there now? If so, enable it and set as default device.

 

Mike

Member
amk4609
Posts: 6

Re: No sound when connecting Laptop to TV

I just tried this system reset, and unfortunately,  still under playback devices only "speakers" is there (with the show disabled, and disconnected devices both checked on).

Very strange.... any other ideas?

Super Advisor
miker643
Posts: 3,438

Re: No sound when connecting Laptop to TV

Click on 'Start', type in   dev  , click on 'Device Manager', click on the arrow beside 'Sound, video and game controllers', make note of the name of your audio device (NOT HDMI)

 

Next, the HDMI is handled by the video/display driver, including the HDMI sound. So, let's try to reload your core set of drivers, chipset, display and audio. Download these files to your desktop and double click to install in this order, reboot if requested:

 

Intel Chipset SW Installation Utility

 

Intel Display Driver

 

 

Then only download and install the appropriate audio/sound driver you made note of above:

 

Conexant Audio Driver

or

nVidia HD Audio Driver

 

 

Then follow the prior steps to try to enable your HDMI audio and set as default device.

 

Let us know what happens. Good luck.

 

Mike

Member
amk4609
Posts: 6

Re: No sound when connecting Laptop to TV

I just tried all those steps of re-installation (and re-booted), and still the only "playback device" is "Speakers" -- no HDMI. :smileysad:

Super Advisor
miker643
Posts: 3,438

Re: No sound when connecting Laptop to TV

Go back into Device Manager, click on the arrow beside Sound, video and game controllers, do a 'PrtScr' (Print Screen) screen shot of this, paste this into Paint, save it as a jpg file, and post this picture back here as an attachment.

 

Mike

Member
amk4609
Posts: 6

Re: No sound when connecting Laptop to TV

[ Edited ]
 
Super Advisor
miker643
Posts: 3,438

Re: No sound when connecting Laptop to TV

Right click on the 'Intel Display Audio', make sure it is enabled, if it is enabled click on 'Properties', what does it say in the 'Device status' box under the 'General' tab?

 

Mike

Member
amk4609
Posts: 6

Re: No sound when connecting Laptop to TV

it was enabled-- it says "This device is working properly."

 

Super Advisor
miker643
Posts: 3,438

Re: No sound when connecting Laptop to TV

At this point all I can suggest is backing up all your user files, music, pictures, etc, then running a Toshiba Recovery to return your unit to its factory default out-of-the-box setup. This is considered the gold standard test on whether you have a hardware problem/failure, as opposed to a driver/update/software conflict. You can read up on the Toshiba Recovery utility starting on page 62 of your User's Guide.

 

Mike